#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*(?:ST|AVENUE|STREET)\b).*"
Local $sString = "9999 ST PAUL ST BSMT" & @CRLF & _
"" & @CRLF & _
"GARRISON BL & BOARMAN AVENUE REAR" & @CRLF & _
"" & @CRLF & _
"1234 MAIN STREET 123" & @CRLF & _
"" & @CRLF & _
"1234 MAIN ST UNIT1"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)