const regex = /(.*(?:ST|AVENUE|STREET)\b).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*(?:ST|AVENUE|STREET)\\b).*', 'gm')
const str = `9999 ST PAUL ST BSMT
GARRISON BL & BOARMAN AVENUE REAR
1234 MAIN STREET 123
1234 MAIN ST UNIT1`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);