re = /(.*(?:ST|AVENUE|STREET)\b).*/m
str = '9999 ST PAUL ST BSMT
GARRISON BL & BOARMAN AVENUE REAR
1234 MAIN STREET 123
1234 MAIN ST UNIT1'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result