import re
regex = re.compile(r"(.*(?:ST|AVENUE|STREET)\b).*", flags=re.MULTILINE)
test_str = ("9999 ST PAUL ST BSMT\n\n"
"GARRISON BL & BOARMAN AVENUE REAR\n\n"
"1234 MAIN STREET 123\n\n"
"1234 MAIN ST UNIT1")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)