import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*(?:ST|AVENUE|STREET)\\b).*";
final String string = "9999 ST PAUL ST BSMT\n\n"
+ "GARRISON BL & BOARMAN AVENUE REAR\n\n"
+ "1234 MAIN STREET 123\n\n"
+ "1234 MAIN ST UNIT1";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}