using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w\d-!$%^&*()_+|~=`{}\[\]:"";'<>?,.\/]+)(.mp4|.avi|.mov)";
string input = @"dvideoimageslide_5563.vi%$%$/&%deo.20190321160326.mp4.1558540973099_html5_api";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}