$re = '/^([\w\d-!$%^&*()_+|~=`{}\[\]:";\'<>?,.\/]+)(.mp4|.avi|.mov)/m';
$str = 'dvideoimageslide_5563.vi%$%$/&%deo.20190321160326.mp4.1558540973099_html5_api';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);