re = /^([\w\d-!$%^&*()_+|~=`{}\[\]:";'<>?,.\/]+)(.mp4|.avi|.mov)/m
str = 'dvideoimageslide_5563.vi%$%$/&%deo.20190321160326.mp4.1558540973099_html5_api'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end