// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^([\w\d-!$%^&*()_+|~=`{}\[\]:";'<>?,.\/]+)(.mp4|.avi|.mov)"#).unwrap();
let string = "dvideoimageslide_5563.vi%$%$/&%deo.20190321160326.mp4.1558540973099_html5_api";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}