const regex = /^([\w\d-!$%^&*()_+|~=`{}\[\]:";'<>?,.\/]+)(.mp4|.avi|.mov)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w\\d-!$%^&*()_+|~=`{}\\[\\]:";\'<>?,.\\\/]+)(.mp4|.avi|.mov)', 'gm')
const str = `dvideoimageslide_5563.vi%\$%\$/&%deo.20190321160326.mp4.1558540973099_html5_api`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}