#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<!(?<!\\)\\)["'])(?:(?=(\\?))\2.)*?(?<!(?<!\\)\\)\1"
Local $sString = "<p>" & @CRLF & _
" <span style="color: #ff0000">"str1"</span> notstr" & @CRLF & _
" <span style="color: #ff0000">"str2"</span>" & @CRLF & _
" \"notstr <span style="color: \"aa #ff0000">"str4"</span>" & @CRLF & _
" \\"hello"" & @CRLF & _
"</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")