import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!(?<!\\\\)\\\\)[\"'])(?:(?=(\\\\?))\\2.)*?(?<!(?<!\\\\)\\\\)\\1";
final String string = "<p>\n"
+ " <span style=\"color: #ff0000\">\"str1\"</span> notstr\n"
+ " <span style=\"color: #ff0000\">\"str2\"</span>\n"
+ " \\\"notstr <span style=\"color: \\\"aa #ff0000\">\"str4\"</span>\n"
+ " \\\\\"hello\"\n"
+ "</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}