using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!(?<!\\)\\)[""'])(?:(?=(\\?))\2.)*?(?<!(?<!\\)\\)\1";
string input = @"<p>
<span style=""color: #ff0000"">""str1""</span> notstr
<span style=""color: #ff0000"">""str2""</span>
\""notstr <span style=""color: \""aa #ff0000"">""str4""</span>
\\""hello""
</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}