const regex = /((?<!(?<!\\)\\)["'])(?:(?=(\\?))\2.)*?(?<!(?<!\\)\\)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<!(?<!\\\\)\\\\)["\'])(?:(?=(\\\\?))\\2.)*?(?<!(?<!\\\\)\\\\)\\1', 'g')
const str = `<p>
<span style="color: #ff0000">"str1"</span> notstr
<span style="color: #ff0000">"str2"</span>
\\"notstr <span style="color: \\"aa #ff0000">"str4"</span>
\\\\"hello"
</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}