re = /((?<!(?<!\\)\\)["'])(?:(?=(\\?))\2.)*?(?<!(?<!\\)\\)\1/
str = '<p>
<span style="color: #ff0000">"str1"</span> notstr
<span style="color: #ff0000">"str2"</span>
\\"notstr <span style="color: \\"aa #ff0000">"str4"</span>
\\\\"hello"
</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end