$re = '/((?<!(?<!\\\\)\\\\)["\'])(?:(?=(\\\\?))\2.)*?(?<!(?<!\\\\)\\\\)\1/';
$str = '<p>
<span style="color: #ff0000">"str1"</span> notstr
<span style="color: #ff0000">"str2"</span>
\\"notstr <span style="color: \\"aa #ff0000">"str4"</span>
\\\\"hello"
</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);