#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Статья(?= \d+\.)"
Local $sString = "Статья 3. Разъяснение некоторы" & @CRLF & _
"Статья 3 дополнена пунктом" & @CRLF & _
"Статья 4. Разъяснение некоторы" & @CRLF & _
"Статья 4 дополнена пунктом" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")