using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Статья(?= \d+\.)";
string input = @"Статья 3. Разъяснение некоторы
Статья 3 дополнена пунктом
Статья 4. Разъяснение некоторы
Статья 4 дополнена пунктом
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}