import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Статья(?= \\d+\\.)";
final String string = "Статья 3. Разъяснение некоторы\n"
+ "Статья 3 дополнена пунктом\n"
+ "Статья 4. Разъяснение некоторы\n"
+ "Статья 4 дополнена пунктом\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}