$re = '/Статья(?= \d+\.)/m';
$str = 'Статья 3. Разъяснение некоторы
Статья 3 дополнена пунктом
Статья 4. Разъяснение некоторы
Статья 4 дополнена пунктом
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);