const regex = new RegExp('Статья(?= \\d+\\.)', 'gm')
const str = `Статья 3. Разъяснение некоторы
Статья 3 дополнена пунктом
Статья 4. Разъяснение некоторы
Статья 4 дополнена пунктом
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}