re = /Статья(?= \d+\.)/m
str = 'Статья 3. Разъяснение некоторы
Статья 3 дополнена пунктом
Статья 4. Разъяснение некоторы
Статья 4 дополнена пунктом
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end