$re = '/^ETB-2022-\d{1,}/m';
$str = 'ETB-2022-01
ETB-2022-02
ETB-2022-03
E-ETB-2022-01
E-ETB-2022-02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);