#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+)(?:\.0+|(\.\d*?)0+)$"
Local $sString = "1.7500" & @CRLF & _
"1.1010" & @CRLF & _
"1.0000" & @CRLF & _
"10" & @CRLF & _
"1.0000010" & @CRLF & _
"1.10" & @CRLF & _
"1.0" & @CRLF & _
"1.10001000102342" & @CRLF & _
"1.10001000102342000000"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)