package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)(?:\.0+|(\.\d*?)0+)$`)
var str = `1.7500
1.1010
1.0000
10
1.0000010
1.10
1.0
1.10001000102342
1.10001000102342000000`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}