const regex = /^(\d+)(?:\.0+|(\.\d*?)0+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)(?:\\.0+|(\\.\\d*?)0+)$', 'gm')
const str = `1.7500
1.1010
1.0000
10
1.0000010
1.10
1.0
1.10001000102342
1.10001000102342000000`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);