use strict;
my $str = '1.7500
1.1010
1.0000
10
1.0000010
1.10
1.0
1.10001000102342
1.10001000102342000000';
my $regex = qr/^(\d+)(?:\.0+|(\.\d*?)0+)$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";