import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)(?:\\.0+|(\\.\\d*?)0+)$";
final String string = "1.7500\n"
+ "1.1010\n"
+ "1.0000\n"
+ "10\n"
+ "1.0000010\n"
+ "1.10\n"
+ "1.0\n"
+ "1.10001000102342\n"
+ "1.10001000102342000000";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}