$re = '/^(\d+)(?:\.0+|(\.\d*?)0+)$/m';
$str = '1.7500
1.1010
1.0000
10
1.0000010
1.10
1.0
1.10001000102342
1.10001000102342000000';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;