using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\*\*[^*]*\*\*[ ]pam_vas:)?\s+([^<:]*):?[ ]<([^>]*)>";
string substitution = @"\1 = \2\r";
string input = @"**Feb 16 20:04:37 hostname su[1111]: [id 123456 auth.info]:** pam_vas: Authentication <succeeded> for <active directory> user: <bobtheperson> account: <bobtheperson@com.com> reason: <N/A> Access cont(upn): <bob>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}