const regex = /(?:\*\*[^*]*\*\*[ ]pam_vas:)?\s+([^<:]*):?[ ]<([^>]*)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\*\\*[^*]*\\*\\*[ ]pam_vas:)?\\s+([^<:]*):?[ ]<([^>]*)>', 'g')
const str = `**Feb 16 20:04:37 hostname su[1111]: [id 123456 auth.info]:** pam_vas: Authentication <succeeded> for <active directory> user: <bobtheperson> account: <bobtheperson@com.com> reason: <N/A> Access cont(upn): <bob>`;
const subst = `\1 = \2\r`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);