import Foundation
let pattern = #"(?:\*\*[^*]*\*\*[ ]pam_vas:)?\s+([^<:]*):?[ ]<([^>]*)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"**Feb 16 20:04:37 hostname su[1111]: [id 123456 auth.info]:** pam_vas: Authentication <succeeded> for <active directory> user: <bobtheperson> account: <bobtheperson@com.com> reason: <N/A> Access cont(upn): <bob>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 = \2\r"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)