import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\*\\*[^*]*\\*\\*[ ]pam_vas:)?\\s+([^<:]*):?[ ]<([^>]*)>";
final String string = "**Feb 16 20:04:37 hostname su[1111]: [id 123456 auth.info]:** pam_vas: Authentication <succeeded> for <active directory> user: <bobtheperson> account: <bobtheperson@com.com> reason: <N/A> Access cont(upn): <bob>";
final String subst = "\\1 = \\2\\r";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}