package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[row]\r?\n([^]*?)\r?\n\[rowEnd]`)
var str = `[row]
Row text1
[rowEnd]
[row]
Row text2
test
[rowEnd]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}