$re = '/^\[row]\r?\n([^]*?)\r?\n\[rowEnd]/m';
$str = '[row]
Row text1
[rowEnd]
[row]
Row text2
test
[rowEnd]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);