re = /^\[row]\r?\n([^]*?)\r?\n\[rowEnd]/m
str = '[row]
Row text1
[rowEnd]
[row]
Row text2
test
[rowEnd]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end