using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bPresident\W+(?:\w+\W+){1,6}?Trump\b";
string input = @"President word1 word2 word3 word4 word5 word6 Trump";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}