$re = '/\bPresident\W+(?:\w+\W+){1,6}?Trump\b/';
$str = 'President word1 word2 word3 word4 word5 word6 Trump';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);