package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bPresident\W+(?:\w+\W+){1,6}?Trump\b`)
var str = `President word1 word2 word3 word4 word5 word6 Trump`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}