const regex = /\bPresident\W+(?:\w+\W+){1,6}?Trump\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bPresident\\W+(?:\\w+\\W+){1,6}?Trump\\b', '')
const str = `President word1 word2 word3 word4 word5 word6 Trump`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}