import Foundation
let pattern = #"\bPresident\W+(?:\w+\W+){1,6}?Trump\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"President word1 word2 word3 word4 word5 word6 Trump"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}