using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(\d+)\.";
string substitution = @".$1,";
string input = @"12,345.67";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}