$re = '`,(\d+)\.`m';
$str = '12,345.67';
$subst = ".$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;