use strict;
my $str = '12,345.67';
my $regex = qr`,(\d+)\.`mp;
my $subst = '.$1,';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";