package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),(\d+)\.`)
var str = `12,345.67`
var substitution = ".$1,"
fmt.Println(re.ReplaceAllString(str, substitution))
}