import re
regex = re.compile(r",(\d+)\.", flags=re.MULTILINE)
test_str = "12,345.67"
subst = ".$1,"
result = regex.sub(subst, test_str)
if result:
print(result)