const regex = new RegExp(',(\\d+)\\.', 'gm')
const str = `12,345.67`;
const subst = `.$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);