#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)-?[$€£]?(\d+(?:[,.]\d+)?)(?!\S)"
Local $sString = "AAA PCSK-9, $111 -3,33" & @CRLF & _
"" & @CRLF & _
"PCSK-9£12" & @CRLF & _
"PCSK-9 £12" & @CRLF & _
"Test €234 test€455 test -100,00 -€1999.00test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")