re = /(?<!\S)-?[$€£]?(\d+(?:[,.]\d+)?)(?!\S)/m
str = 'AAA PCSK-9, $111 -3,33
PCSK-9£12
PCSK-9 £12
Test €234 test€455 test -100,00 -€1999.00test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end