import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)-?[$€£]?(\\d+(?:[,.]\\d+)?)(?!\\S)";
final String string = "AAA PCSK-9, $111 -3,33\n\n"
+ "PCSK-9£12\n"
+ "PCSK-9 £12\n"
+ "Test €234 test€455 test -100,00 -€1999.00test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}